mysql-4.0.13: description + notes

MySQL is a very fast, multi-threaded, multi-user, and robust SQL (Structured Query Language) database server. The MySQL web site has more details. Note that simply installing fw_mysql does not create a mysql user or change ownership of the /var/spool/mysql directory tree.

MySQL version 4.0 has been declared stable, and can now be safely used in production environments. This means that, in the future, only bug fixes will be done for the 4.0 release series, and only critical bug fixes will be done for the older 3.23 series.

This package has been compiled with Berkeley DB and InnoDB transactional tables, and with tcp_wrappers and OpenSSL support.

NOTE: If you are running IRIX 6.5.18, 6.5.19, or 6.5.20 mysqld may experience pthread deadlocks unless you install patch 5119 (f-stream) or 5120 (m-stream).

Upgrading from version 3.23 to 4.0

Once you have installed MySQL 4.0, you can still use your 3.23 tables. During the installation, infact, your databases will not be touched. However, you should take note of the following:

To upgrade your tables to version 4.0, you can follow these steps (as a DB administrator):

Once you have upgraded you databases, you can still downgrade to MySQL 3.23.52 or newer if you run into problems with the MySQL 4.0 series. In this case you have to do a mysqldump of any tables using a full-text index and restore these in 3.23 (because 4.0 uses a new format for full-text index).

Client shared libraries compatibility

With MySQL 4.0 the data structures in the client libraries ( and its thread safe version, have been changed. If you have any MySQL clients that have been linked against the previous 3.23 shared libraries you must recompile them using the new libraries provided with this package. In order to provide a smooth path to the upgrade, and to support some older SGI freeware packages that still rely on the old client libraries, the 3.23 shared libraries are installed as well as the 4.0 counterparts. Please note that you should not link your applications against the 3.23 shared libraries (and indeed, it's not supported!): they have been retained only for compatibility reasons and will removed once all the SGI freeware packages depending on them will have been updated.

Older clients, especially if linked against the static libraries, should work with MySQL 4.0 server without any problems. Please refer to the installed MySQL documentation for further information.

Special thanks to Andrea Suatoni ( for helping port this package to IRIX.
To auto-install this package, go back and click on the respective install icon.